Learn how to join our server and start playing in 60 seconds!
Play Now
  • Hey Guest, If you have any suggestions regarding the Forums/Website we would love to hear them!

Denied Classic SkyBlock We need back 1.8.9 version we need the old classic skyblock first remove protection 6 protection 7 a

AlexandrosGR

Pika Member
Joined
Oct 6, 2020
Messages
34
Points
8
Minecraft Username:
AlexandrosGR​

Suggestion:
We need back 1.8.9 version we need the old classic skyblock first remove protection 6 protection 7 and protection 8 remove 1.16+ version add new gkits like santa kit and more remove netherite armor.And we need back outposts we need only a classic skyblock now classic skyblock is like opsky keep protection 1,2,3,4,5 and remove prot 6,7,8​

Detailed description:
Just change version we need back 1.8.9 and remove protection 6,7,8​

Reason(s):
 

billgamer2007

Legendary Pika
Joined
Oct 31, 2020
Messages
208
Points
33
AlexandrosGR

Suggestion:
We need back 1.8.9 version we need the old classic skyblock first remove protection 6 protection 7 and protection 8 remove 1.16+ version add new gkits like santa kit and more remove netherite armor.And we need back outposts we need only a classic skyblock now classic skyblock is like opsky keep protection 1,2,3,4,5 and remove prot 6,7,8

Detailed description:
Just change version we need back 1.8.9 and remove protection 6,7,8

Reason(s):
i agree with this noob guy we need back our old classic skyblock like 4/5 season ago and add new kits/gkits and add more /levels so everybody can take some rewards by doing challenges and waste his time with them.
MineCraft UserName: billgamer2007
Ranks:
OpSkyblock: SkyHero , Classic Skyblock: SkyLegend
 

Diamond_Gamerzz

Legendary Pika
Joined
Jul 16, 2021
Messages
384
Points
33
Minecraft Username:
AlexandrosGR

Suggestion:
We need back 1.8.9 version we need the old classic skyblock first remove protection 6 protection 7 and protection 8 remove 1.16+ version add new gkits like santa kit and more remove netherite armor.And we need back outposts we need only a classic skyblock now classic skyblock is like opsky keep protection 1,2,3,4,5 and remove prot 6,7,8

Detailed description:
Just change version we need back 1.8.9 and remove protection 6,7,8

Reason(s):
I agree to the version change back to 1.8.9 because skyblock was way more fun in 1.8.9. It was also easy to access because most people who play bedwars can just come and play skyblock without changing version, now i have to open 1.17 and change to 1.8.9 if i wanna play bedwars. also bring back comps its good for new players to get on the island top easily other than when rich players just buy tons of keys and be on the island top. Removing the prot 6,7,8 armour is also good so fights end faster, if there are higher prots than normal it just takes forever. the outposts were a good source of money boosters and exp boosters too. I hope these get added soon it will be so much fun.
 

ElementalMCR

Veteran
Great Reporter
Joined
Jul 11, 2021
Messages
931
Points
48
I like the idea of bringing back 1.8.9 and the outposts but.. I'm against the idea of removing 6/7/8 prot.
 

KuskyLOL

Epic Pika
Joined
Mar 23, 2021
Messages
159
Points
23
Minecraft Username:
AlexandrosGR

Suggestion:
We need back 1.8.9 version we need the old classic skyblock first remove protection 6 protection 7 and protection 8 remove 1.16+ version add new gkits like santa kit and more remove netherite armor.And we need back outposts we need only a classic skyblock now classic skyblock is like opsky keep protection 1,2,3,4,5 and remove prot 6,7,8

Detailed description:
Just change version we need back 1.8.9 and remove protection 6,7,8

Reason(s):
I agree but meaby prot 6/7/8 dont need to be removed if it get removed then p5 need to be added on suplys cuz lot ppl who is good at csb dont got god or king rank and its hard to get p5 (just like me :D)
 

MrRRaw

Member
Joined
Apr 25, 2020
Messages
9
Points
3
I agree but meaby prot 6/7/8 dont need to be removed if it get removed then p5 need to be added on suplys cuz lot ppl who is good at csb dont got god or king rank and its hard to get p5 (just like me :D)
Kusky no p5 in drops bc then skygod is no point to buy
 

MnAMnOYEKAE

Pika Member
Joined
Dec 30, 2020
Messages
39
Points
8
I agree, 1.8 was better and more fun. P6+ also has to be removed, i mean, its called classic skyblock for a reason, just like we dont have sharpness 6 we should'n have prot6/7/8. Protection 5 should be only in skygod and skyking because thats one of the main reasons people buy the ranks at the first place. If they didn't have that advantage they wouldnt really worth it.
 

Phantoom

Great Reporter
Joined
Jul 28, 2020
Messages
297
Points
43
+1
Pretty sure this is gonna get denied tho
 

Blazemon

The Pika
Joined
Dec 16, 2020
Messages
1,712
Points
98
Why tf would there be enchants over prot 5 in CLASSIC skyblock?
+1
 

vladmafiaboss

Member
Joined
Feb 15, 2021
Messages
8
Points
1
Minecraft Username:
AlexandrosGR

Suggestion:
We need back 1.8.9 version we need the old classic skyblock first remove protection 6 protection 7 and protection 8 remove 1.16+ version add new gkits like santa kit and more remove netherite armor.And we need back outposts we need only a classic skyblock now classic skyblock is like opsky keep protection 1,2,3,4,5 and remove prot 6,7,8

Detailed
Minecraft Username:
AlexandrosGR

Suggestion:
We need back 1.8.9 version we need the old classic skyblock first remove protection 6 protection 7 and protection 8 remove 1.16+ version add new gkits like santa kit and more remove netherite armor.And we need back outposts we need only a classic skyblock now classic skyblock is like opsky keep protection 1,2,3,4,5 and remove prot 6,7,8

Detailed description:
Just change version we need back 1.8.9 and remove protection 6,7,8

Reason(s):
i agree bring back the 1.8.9 pvp and remove the prot 6+
 

Vitilz

Member
Joined
Aug 31, 2020
Messages
9
Points
3
i strongly agree with this, the server was amazing and i understand your trying new things to make the server better but the community that has been here from the start does not agree and would like to go back to the old ways, the good ways
 

itsdruglovexx

Great Reporter
Joined
Feb 9, 2020
Messages
629
Points
58
To be as classic as possible, bring back 1.8 skyblock, don't make it pvp focused, let players grind for thier stuff (keep the supply drops). Remove the whole 1.17 idea, it ruined grinding and it makes players cheat even more while being undetectable (u must click low cps so u can grind, and if the hacker is smart bingo u have undetected cheater). Balance the gkits, since i want payouts back and spawners gkit is a bit too op if u have like 6 of them, u instantly get on top. Make it as a block value so the spawners wont be too op. Next remove money boosters from everywhere, except for levels. Buff the player levels rewards. Remove the hats, or lower their chances of getting them (i know its there to balance the economy but getting 5 hats of 10 godlies is a scam, id rather get cash/mobcoins). Don't bring back outposts because it was a scam ever since it was there, 50 people go on 20.
The thing about Classic Skyblock is to make it as classic as possible, all the players to have +- same perks. Of course ranks exist and they give certain perks, same as gkits, but yea i think id rather grt nerfed and enjoy than get "clapped" by no skill p2winner. Also remove the seasonal crate.
Thats all for now
Make the island member size 8-12 max with member upgrade vouchers.
PS: this is a suggestion for the next season, whenever u decide to launch it.
 

TheDynamicGamer

The Pika
Joined
Dec 4, 2020
Messages
1,549
Points
88
Minecraft Username:
AlexandrosGR

Suggestion:
We need back 1.8.9 version we need the old classic skyblock first remove protection 6 protection 7 and protection 8 remove 1.16+ version add new gkits like santa kit and more remove netherite armor.And we need back outposts we need only a classic skyblock now classic skyblock is like opsky keep protection 1,2,3,4,5 and remove prot 6,7,8

Detailed description:
Just change version we need back 1.8.9 and remove protection 6,7,8

Reason(s):
+1
This is so true. They changed all gamemodes to be for 1.14+ and im too lazy to close mc and reopen on different version. (I'd start using sigma for the epik version changer it has, dont ask me how i know about that)
Plus, they made it more unfair for newer players agaisnt older ones with good ranks.
 
Top